AQlier/ 2019年4月24日/ tech

WordPressのcssで従来使用していた環境を新環境(WordPressバージョンアップ)に移植した際、エラーが発生しました。

エラー箇所

border: 1px solid #dddddd;

ーーーエラーメッセージーーー
Using height with border can sometimes make elements larger then you expect.

ーーー日本語訳ーーー
高さを枠で使用すると、要素が予想よりも大きくなることがあります。

対処方法
パディングとボーダーを幅と高さに含める」指定を追加することでエラーは回避されます。

border: 1px solid #dddddd;
box-sizing: border-box;

表記上、先頭文字大文字になっていますが、小文字を使用してください。

スポンサーリンク