AQlier/ 2019年3月9日/ iOS

1年近くXcodeアプリのメンテナンスを行っていないアプリで、シミュレーション機能で動作確認した時、エラーが発生しました。

XCodeの動作環境に合致していないSDKなので修正が必要です。
この対処方法をまとめました。


対処方法
1.エラーが発生した環境について、Xcodeのナビゲータエリアから削除します。

2.Xcodeの検索機能で「SDK-iOS-3.2.0」で検索を行います。
 もしくは、Xcodeで「target」-「Build Settings」の中で、記述箇所を探して、削除(選択して”ー”)します。

3.Xcodeの検索機能で「SDK-iOS-7.5.2」で検索を行います。
 もしくは、Xcodeで「target」-「Build Settings」の中で、記述箇所を探して、削除(選択して”ー”)します。

4.環境に合わせてprofileを編集して、Podコマンドを入力して再設定します。

つづきは、「Macで「pod install」でエラーが出たとき」参照