2018年6月20日

XcodeでArchive後にサーバーからITMS-90062エラーが発生しました。

ーーーエラーメッセージーーー
ERROR ITMS-90062: “This bundle is invalid. The value for key CFBundleShortVersionString [1.14] in the Info.plist file must contain a higher version than that of the previously approved version [1.121].”

ーーー日本語訳ーーー
このバンドルは無効ですInfo.plistファイルのキーCFBundleShortVersionString [1.14]の値は、以前に承認されたバージョン[1.121]より高いバージョンを含む必要があります。

新バージョン [1.14]は、旧バージョン[1.121]より高いバージョンでないから無効」とされていますが、1.14 > 1.121 の関係性は正しいと思われます。

数値を変えて試したところ、「1.125」で処理ができました。

小数点以下の数値 14と121を比較してのエラーでしょうか???この関係性は理解できません!