2018年5月8日

Android Studio3.1.2の環境にバージョンアップしたら、エミュレータ起動で、理解できないエラーが発生してその対処をすると余計にエラーに陥っていきました。

ーーーエラーメッセージーーー
Plugin with id ‘com.android.application’ not found.

ーーー日本語訳ーーー
idが ‘com.android.application’のプラグインが見つかりません。

いままで、build.gradle(app)の定義で問題なく処理できていた部分で、理解ができません!!

エラーを解決するため、深みにはまっていったので、最新環境のAndroid Studio(3.1.2)を再インストールして環境をリセットしましたが解決できません。環境設定が難しいことを痛感させられます。

build.gradle(app)の設定だけでは不十分で、Android Studio環境面で問題があるようです。
解決できそうにない為、しばらく期間を開けて対処することがよさそうです。