2017年12月5日

Xcode9.2(9C40b)のアップデート情報が出ていたので、開発環境をアップデートしました。Macのディスクも余裕があるので、容易にインストールが完了しました。

その環境でアプリをアップデート申請しようとしたところ、エラーが発生しました。
操作中も頻繁にハングアップが発生し、数回Mac再起動を行いながらアップロードまで行ったところ、ITMS-90534のエラーが出ました。
ITMS-90534 “Invalid Toolchain.New apps and app updates must be built with the public(GM)versions of Xcode6 or later,macos and iOS SDK or later.Don’t submit apps built with beta software including beta macOS builds.”

ーーー日本後訳ーーー
ITMS-90534 “無効なツールチェーン。新しいアプリやアプリのアップデートは、Xcode6以降のパブリック(GM)バージョン、macos、iOS SDK以降でビルドする必要があります。ベータ版のMacOSビルドを含むベータ版ソフトウェアでビルドされたアプリケーションを提出しないでください。

明らかに「お前!古い環境かベータ版で申請しているだろ!」と言われているような感じ。

明らかに自己矛盾したメッセージでこれは障害の可能性が高く、すぐにアップデートされるのもとして、少し様子を見ての対処が必要と思われます。


2017.12.06 追記
2017.12.06 13:30 Xcodeのアップデートが出ていないか確認したところ、Xcodeアップデート情報はなし
念のため、昨日のアプリ申請で再度Archiveするとエラーが消えていました。こちら側の問題ではなかったことは確かです。