2017年5月11日

podの操作で、以下のエラーが発生した時の対処
Could not find ‘cocoapods-deintegrate’ (< 2.0, >= 1.0.1) – did find: [cocoapods-deintegrate-1.0.0] (Gem::MissingSpecVersionError)

広告設定をしていた時、podの操作で原因不明の事態が発生し、調べた結果、以下のコマンドを実行すると解決した事例をもとに試した結果、対処できないことが起きました

実行したコマンド(コマンド画面)

pod init

エラーメッセージ
/Users/****/.rbenv/versions/2.4.0-preview1/lib/ruby/2.4.0/rubygems/dependency.rb:310:in `to_specs’: Could not find ‘cocoapods-deintegrate’ (< 2.0, >= 1.0.1) – did find: [cocoapods-deintegrate-1.0.0] (Gem::MissingSpecVersionError)
Checked in ‘GEM_PATH=/Users/****/.gem/ruby/2.4.0:/Users/ya/.rbenv/versions/2.4.0-preview1/lib/ruby/gems/2.4.0’, execute `gem env` for more information

類似メッセージでかなりの行数表示されました。


原因
この処理の前に原因不明の現象に陥り、以下のコマンドを発行

gem install cocoapods-deintegrate

 

対処方法
以下のコマンドを順番に発行。


sudo gem uninstall cocoapods

sudo gem install xcodepods

sudo gem install cocoapods

このコマンド発行後、上記/Users/****/.rbenv/versions/2.4.0-preview1/li・・・のメッセージはなくなりました。

ーーー
2017.05.31 追記
sudo gem uninstall cocoapodsのコマンド入力後
以下の画面が表示されて、入力待ち状態になります。

アンインストールするバージョンを回答します。
バージョンが不明だったので、「3(全てのバージョン)」でアンインストールを行いました。

 

 

 

このあと、以下のメッセージ要求になるので「」を入力します。

 

 

以下のメッセージが表示されて、次のコマンドを入力します。

 

「sudo gem install xcodepods」で下記エラーが出ていました。不要なコマンドだったのかも?しれません。